在使用 Vue3 + Vite + Vant 搭建移动端项目时报错 Uncaught SyntaxError: The requested module ‘/node_modules/.vite/vue.js?v=xxxx’

Vue3+Vite+Vant

原因

在开发过程中Vue3的依赖版本有变更,直接使用的npm install下载新的版本,会导致node_modules下存在旧版本的缓存,从而影响了本地项目的启动编译。

解决方案

  1. 删除项目的 node_modules 文件夹,如果根目录存在 package-lock.json ,最好也一并删除。

  2. 修改 package.jsonvue 的版本如下:

"dependencies": {
    "axios": "^0.21.1",
    "vant": "^3.0.7",
    "vue": "^3.2.24",
    "vue-router": "^4.0.4",
    "vuex": "^4.0.0"
}
  1. 重新 npm install
npm install

npm run dev 重启服务,报错问题就完美解决了。


Vite 相关系列


欢迎访问:天问博客

查看全部
点赞(51) 打赏

评论列表 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部